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Introduction 
This document is written for Eclipse/Java developers creating tool-components for the IBM 
Rational v7 Desktop platform who want to provide the users/practitioners with specific guidance on 
how to use their tool in the context of process. Thus, this whitepaper will show you the basics to 
develop provider plug-ins that display the context sensitive information for your tool in the Process 
Advisor view. Specifically, this white paper will explain: 
 

·  How to create a process configuration provider and a process context provider plug-ins.  
·  Provide you with a process context bundle sample. You can use the sample as templates 

that will help you create your own custom providers.  
·  Give you an understanding of all your available options and show you what you can do with 

the technology in its current state. 
 
It is important to understand that this paper is not intended to explain how to use the Rational 
Method Composer (RMC) tool - it assumes that your organization has already written/authored the 
content for your guidance and utilized RMC to publish the process configuration that contains 
them. 
 

Key Terminology and Concepts 
Here some terminology that will be used throughout the rest of this document. 
 
- Process Advisor provides real-time, context-sensitive process guidance to a software 

practitioner working within the IBM Rational v7 Desktop Products. 
- Process Browser allows a software practitioner to browse a process configuration within the 

IBM Rational v7 Desktop Products. 
- Process Search allows a software practitioner to search a process configuration for specific 

guidance within the IBM Rational v7 Desktop Products. 
- Process Preference Page allows a software practitioner to customize/filter the process 

guidance displayed in the Process Advisor. 
- Extension Points is the way the custom config and context providers extend the functionality of 

the core process plug-in in a controlled manner. 
- Software componentization is the movement of IBM software development from a monolithic, 

product-oriented development model to one based on the concept of software offerings 
composed from the sharing of reusable software components. 

 

Prerequisites 
Before you begin to create a config and a context provider, you will need to use one of the IBM 
Rational v7 Desktop Products listed below as you development and test environment: 
 

·  Rational Application Developer (RAD) 
·  Rational Software Architect (RSA) 
·  Rational Software Modeler (RSM) 
·  Rational Systems Developer (RSD) 
·  Rational Functional Tester (RFT) 
·  Rational Manual Tester (RMT) 
·  Rational Performance Tester (RPT) 
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Creating a Process Configuration Provider Plug-in 
 
The first step is to create a plug-in project using the Eclipse New Project wizard: 
 
·  From the File menu, select New > Project to launch the New Project wizard. 
·  On the first page of the wizard, select Plug-in Development > Plug-in Project from the list, 

followed by the Next button. 
  

 
 
 
·  On the next page of the wizard, enter the name of the project; in this case, it is 

com. i bm. pr ocess. conf i g. t ool , uncheck the Create a Java project option, and click the 
Next button. 
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·  Each plug-in has a manifest file named MANIFEST.MF that defines the plug-in and how it 

relates to other plug-ins in the system. The next wizard page displays options for generating 
the plug-in manifest. Change the Plug-in Name to Tool Configuration Provider Plug-in and 
press the Finish button. 
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The plug-in manifest editor is automatically open to its first page as a result of creating a new plug-
in project. If the plug-in manifest editor is closed, then double-clicking on the MANIFEST.MF file in 
the Package Explorer view reopens the editor. 
 
·  Select the Extensions tab and click the Add button, as shown below. 
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·  Uncheck the Show only extension points from the required plug-ins check-box and select 

the com. i bm. pr ocess. conf i gPr ov i der s extension point. Then, press the Finish button. 
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·  Select No in the following dialog box and save all the changes. 
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Notice that the plugin.xml file has been added to the project. So, double-click on the plugin.xml file 
to edit it. 
 

 
 

 
·  Select the plugin.xml tab so you can manually edit the extension point and add the 

configuration information of your process description. 
 

 
 
·  Add the following XML text inside the extension point tag, as shown below. 
 

<conf i gur at i on 
      i d=" com. i bm. pr ocess. conf i g. t ool "           
      name=" Tool  Pr ocess Conf i gur at i on"  
      pat h=" cont ent . zi p"    
      r ol es=" " > 
</ conf i gur at i on> 
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The value assigned to the path attribute tells the config provider plug-in the name of the ZIP file 
that contains the custom process configuration published by RMC. You can ignore the roles 
attribute for now. 
 
Create the content.zip file and copy it into the com.ibm.process.config.tool project as shown below. 
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·  Double-click on the build.properties file in the Package Explorer view and select the new 

added content.zip file to include it in the binary build definition, as it is illustrated below. 
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·  To test your config provider plug-in, run it as an Eclipse Application. 
 

 
 

 
·  In the new Eclipse instance, select Window > Preferences… and click Process. You should 

see your process configuration listed in drop-down list, as shown below. Select it and press OK 
button. 
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·  From the Help menu, select Process Browser to view the selected configuration. The figure 

below shows a sample of a Tool Mentor for the Rational Software Architect (RSA) tool. 
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Creating a Process Context Provider Plug-in 
 
Create another plug-in project using the Eclipse New Project wizard: 
 
·  From the File menu, select New > Project to launch the New Project wizard. 
·  On the first page of the wizard, select Plug-in Development > Plug-in Project from the list, 

followed by the Next button. 
·  On the next page of the wizard, enter the name of the project; in this case, it is 

com. i bm. pr ocess. cont ext . t ool , and click the Next button. 
 

 
 
Notice that you now have to leave checked the Create a Java project option since we will be 
creating Java classes for this project. 

 
·  The next wizard page displays options for generating the plug-in manifest. Change the Plug-in 

Name to Tool Context Provider Plug-in, and press the Finish button. 
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The plug-in manifest editor is automatically open to its first page as a result of creating a new plug-
in project. If the plug-in manifest editor is closed, then double-clicking on the MANIFEST.MF file in 
the Package Explorer view reopens the editor. 
 
·  Select the Dependencies tab and add the following required dependencies, as shown below. 
 

- com.ibm.process.context 
- org.eclipse.jface.text 
- org.eclipse.ui 
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·  Now, select the Extensions tab, click the Add button, uncheck the Show only extension 

points from the required plug-ins check-box, and select the 
com. i bm. pr ocess. cont ext Pr ovi der s extension point. Then, press the Finish button. 

·  Once again, answer No to the question regarding adding the list of plug-in dependencies. 
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·  Select the plugin.xml tab to manually edit the extension point and add your context provider 

information. 
·  For this example, go ahead and add the following XML text into the <extension point> element, 

as shown below. 
 

<cont ext Pr ovi der   
    c l ass=" com. i bm. pr ocess. cont ext . t ool . Tool Pr ocessCont ext Pr ovi der "  
    per spect i ve=" or g. ecl i pse. j dt . ui . JavaPer spect i ve"  
    par t ="  or g. ecl i pse. ui . edi t or s. t ext . Text Edi t or "  
    sel ect i on="  or g. ecl i pse. j f ace. t ext . Text Sel ect i on" > 
</ cont ext Pr ovi der > 

 

 
 
Notice that you may define more than one contextProvider element; which allows greater flexibility 
to implement the same context extension for multiple parts and perspectives. The attributes are: 
 

class� The fully qualified name of the class defining the context provider and implementing 
the I Pr ocessCont ext Pr ovi der  
 
perspective� The unique identifier used to reference the perspective. 
 
part� The fully qualified name of a class that inherits from any workbench parts, which come 
in two varieties: viewes and editors. 
 
selection� The fully qualified name of a class that inherits from ISelection. 
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As you can see, each contextProvider element is attached to an individual perspective, part, and 
selection that it wants to observe. 
 
·  Let’s now create the Tool Pr ocessCont ext Pr ov i der  class that implements the 

com. i bm. pr ocess. cont ext . I Pr ocessCont ext Pr ov i der  interface. 

·  Right-click on the src folder and select New > Package or click the  New Java Package 
toolbar button to open the New Java Package wizard, as shown below. 

 

 
 
 
·  Enter the name of the package (e.g.: com. i bm. pr ocess. cont ext . t ool ) and click the 

Finish button. 
 
 



Copyright © 2006 IBM Corporation 20 

 
 
 
·  Now, right-click on the com.ibm.process.context.tool package and select New > Class or click 

the  New Java Class toolbar button to open the New Java Class wizard, as seen below. 
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·  Enter Tool Pr ocessCont ext Pr ov i der  as class name. Notice that it needs to match the 
value for class attribute in the contextProvider tag. 

·  Click the Add… button to add the I Pr ocessCont ext Pr ovi der  interface, and click the 
Finish button. 

 
 

 
 
 
So what’s next? You’ve got a class that you can use to return process context given the 
perperspective identifier, the IWorkbenchPart, and/or the ISelection objects. 
 
For this exercise, add the code highlighted below to tell the instance of the 
ToolProcessContextProvider class  
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Let’s test the context provider plug-in: 
 
·  Run it as an Eclipse application. 
·  Then, switch to the Java perspective and select Help > Process Advisor. The process 

guidance for “java” should be displayed, as shown below. 
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Notice that the Search query panel in the Process Advisor view is turned Off by default.  However, 
for testing and debuggin purpose, it can be turned On by setting displaySearchInAdvisor=true in 
the ..\plugins\com.ibm.process_7.0.0\plugin.properties file. 
 
·  Create a General project by selecting File > New > Project… > General > Project. Name it 

Test. 
 
·  Add a text file. Right-click on the Test project and select New > File, as shown below. 
 

 
 
 
·  Select the editor for the TextFile file. The process guidance for “uml” should be displayed, as 

shown below. 
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The first step is to create a plug-in project using the Eclipse New Project wizard: 
 
 

Context Bundle 
We now turn our attention to providing context-sensitive query strings that the Process Advisor 
view will dynamically use to search and display the process guidance for your tool. So, let’s create 
a class that extends the ProcessContextBundle class. 
 
·  Right-click on the com.ibm.process.context.tool package and select New > Class or click the 

 New Java Class toolbar button to open the New Java Class wizard. 
·  Enter Tool Pr ocessCont ext Pr ov i der  as class name. Notice that it needs to match the 

value for class attribute in the contextProvider tag. 
·  Click the Browse… button to add the Pr ocessCont ext Bundl e class, and click the Finish 

button. 
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·  Copy and paste the following code into the new bundle class. 
 

pr i vat e f i nal  st at i c Resour ceBundl e BUNDLE = Resour ceBundl e 
 . get Bundl e( RADPr ocessCont ext Bundl e. cl ass. get Package( ) . get Name( )  
  + " . Pr ocessCont ext s" ) ;  / / $NON- NLS- 1$ 
 
  
publ i c st at i c I Pr ocessCont ext  get Cont ext ( St r i ng key)  {  
 r et ur n get Cont ext ( BUNDLE,  key) ;  
}  
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The ToolProcessContextBundle class includes the getContext() method; which returns the process 
context associated with the given keyword, respectively, for a given selection. We use Java’s 
ResourceBundle mechanism to supply externalized query strings.  Each context provider plug-in 
can include a property file, called ProcessContexts.properties, that defines the mapping of tool-
specific contexts to process search queries. 
 
·  Right-click on the com.ibm.process.context.tool package and select New > File, name the file 

ProcessContexts.properties, as shown below. 
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·  Add the following strings into the ProcessContexts.properties file. 
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Now, update the Tool Pr ocessCont ext Pr ov i der  class with the changes highlighted below. 
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Let’s test the context provider plug-in: 
 
·  Run it as an Eclipse application. 
·  Then, switch to the Java perspective and select Help > Process Advisor.  
·  Open the TextFile we created early and type the words uml and interface. 
·  If you highlight the word uml, then you will see context sensitive query string displayed in the 

Search query text box and the Process Advisor view populated with guidance, as shown 
below. 
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As you can see the system provides dynamic search results based on the context of the focus in 
the editor. Also, if you clicking on a link in the Process Advisor view, then it will open the Process 
Browser window to display the topic content. 
 
Notice that the nature of the content available to be searched and displayed is dependent upon the 
referenced process configuration in the selected config provider. 
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Notices 

Trademarks and service marks 
The following terms are trademarks or registered trademarks of the IBM Corporation in the United 
States, other countries, or both: 
 
IBM 
 
Rational 
 
Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun 
Microsystems, Inc. in the United States, other countries, or both. 
 
Eclipse, Built on Eclipse and Eclipse Ready are trademarks of Eclipse Foundation, Inc. 
 
Other company, product, and service names may be trademarks or service marks of others. 


